ชื่อผู้ใช้งาน
รหัสผ่าน:
 
หน้า: [1]
  พิมพ์  
 
ผู้เขียน หัวข้อ: วิธีแก้ปัญหา \\computer is not accessible. You might not have permission to use  (อ่าน 10992 ครั้ง)
กุมภาพันธ์ 02, 2010, 01:37:50 pm
อ.สมฤกษ์
Hero Member
*****
กระทู้: 852



อีเมล์
« เมื่อ: กุมภาพันธ์ 02, 2010, 01:37:50 pm »

วิธีแก้ปัญหา \\computer is not accessible. You might not have permission to use this network resorce ....

เคยเจอไหมครับ เวลาที่เราเชื่อมต่อเน็ตเวิร์คระหว่างเครื่อง หรือแชร์ข้อมูลเพื่อให้อีกเครื่อง สามารถเข้าไปดึงเอาข้อมูลที่แชร์ไว้ได้ แล้ววินโดวส์ xp จะฟ้องว่า “\\computer is not accessible. You might not have permission to use this network resource.” วันนี้ผมทิป ทริก เทคนิค วิธีเพื่อแก้ปัญหานี้ มาฝากกันครับ มีวิธีการอย่างไร มาดูกันต่อเลยดีดว่านะครับ

ขั้นแรก ให้เช็ค Workgroup ของเครื่องที่จะเชื่อมต่อ และแชร์ข้อมูล โดยจะต้องเป็นชื่อ workgroup เดียวกัน รวมไปถึงชื่อ workgroup ถ้าเป็นตัวพิมพ์เล็ก ก็ต้องตัวพิมพ์เล็กเหมือนกัน แต่ถ้าเป็นตัวพิมพ์ใหญ่ ก็ต้องตัวพิมพ์ใหญ่เหมือนกัน สามารถเช็คหรือเปลี่ยนแปลงโดยคลิกขวา My Computer > Properties > Computer Name > คลิกปุ่ม Change แล้วแก้ไข Workgroup ตัวอย่างดังรูป


ขั้นที่สอง ให้เช็คว่าได้เลือก File and Printer Sharing ไว้หรือเปล่า โดยไปที่ Start > Control Panel > Network Connections > คลิกขวาที่ network ที่กำลังเชื่อมต่ออยู่ > เลือก Properties > ถ้า File and Printer Sharing for Microsoft Networks ไม่ได้ติ๊กถูก ให้ติ๊กถูกข้างหน้าข้อความนี้ ดังรูป


ขั้นที่สาม ให้เช็คว่าได้ใช้ TCP/IP Protocol หรือไม่ โดยไปที่ Start > Control Panel > Network Connections > คลิกขวาที่ network ที่กำลังเชื่อมต่ออยู่ > เลือก Properties > ถ้า Internet Protocol(TCP/IP) ไม่ได้ติ๊กถูก ให้ติ๊กถูกข้างหน้าข้อความนี้ ดังรูป


ขั้นที่สี่  ให้เช็ค Subnet Mask, Default Gateway และ IP address โดยไปที่ Start > Run > แล้วพิมพ์ cmd จากนั้นกดปุ่ม Enter จะมีหน้าจอสีดำปรากฏขึ้นมา ที่หน้าจอสีดำ ให้พิมพ์คำสั่ง ipconfig /all เพื่อดูค่า Subnet Mask, Default Gateway และ IP address ว่าตรงกันหรือไม่ ดังรูป


ขั้นที่ห้า  ให้เช็คไฟร์วอล(Firewalls) โดยไปที่ Start > Control Panel > Windows Firewall > เลือกแท๊บ Exceptions แล้วดูว่า ที่หน้าข้อความ File and Printer Sharing ได้ติ๊กถูกอยู่หรือไม่ ถ้าไม่ให้ติ๊กถูก ดังรูป



ขั้นที่หก  ให้เช็คเรื่องของการ Share Permissions ว่าได้เปิดให้ everyone สามารถ access เข้าเครื่องหรือ folder ที่แชร์ได้ไหม ดังรูป


ถ้าไม่มีให้ไปที่
My Computer
ต้องไปที่เมนู Tools เลือกคำสั่ง Folder Options...
--> View
--> Use simple file sharing (Recommended) (เอาเครื่องหมายถูกด้านหน้าออกซะ)
--> OK

ขั้นที่เจ็ด  ให้เช็ค Username และ Passwords ว่าระหว่างเครื่องที่เชื่อมต่อ และแชร์ข้อมูลกันนั้น ใช้ Username และ Password อันเดียวกันหรือไม่ ถ้าไม่มี ให้สร้าง accounts ขึ้นมาให้ โดยให้ Username และ Passwords เป้นอันเดียวกัน ระหว่างเครื่องที่จะเชื่อมต่อหรือแชร์ข้อมูลกัน และ Username นั้นก็อยู่ในกลุ่ม Administrators ด้วย


ขั้นที่แปด  ให้เรื่องของ Computer Name โดยชื่อเครื่องจะต้องไม่เหมือนกัน และจะต้องมีจำนวนตัวอักขระน้อยกว่าหรือเท่ากับ 8 ตัวอักขระ เช่น ถ้าใช้ชื่อ mycomputer1 กับ mycomputer2 ถ้านับจำนวนอักขระแล้ว 8 ตัว จะได้ mycomput ซึ่งวินโดวส์จะมองว่า NetBIOS name นี้ เป็นอันเดียวกัน ทำให้มีปัญหาได้


ขั้นที่เก้า  ***ส่วนใหญ่มักเป็นที่ข้อนี้ครับ***
ให้เช็คเรื่องของ Local Security Policy โดยไปที่
Start
> Control Panel
> Administrative Tools
> Local Security Policy
> Local Policies
> Security Options แล้วหาข้อความ
Network access: Do not allow anonymous enumeration of SAM accounts and shares

ดังรูป


แล้วดูว่าคอลัมน์ Security Setting เป็น Disabled อยู่หรือไม่
ถ้าไม่ ให้ดับเบิ้ลคลิกที่ “Network access: Do not allow anonymous enumeration of SAM accounts and shares”
แล้วเลือก Disabled
> Apply
> OK

ขั้นสุดท้าย ขั้นที่สิบ  ให้เช็คเรื่องของโปรแแกรม Antivirus และ Internet Security ทั้งหลาย ว่ามันบล็อค connection หรือเปล่า ยกตัวอย่าง โปรแกรมNorton Internet Security หรือ Kaspersky Internet Security ถ้าโปรแกรมเหล่านั้นมันบล็อคให้ Disable มันไปซะ แล้วลอง Test Connection ดูใหม่อีกที

แหล่งข้อมูลอ้างอิง
http://www.thaigaming.com/articles/70359.htm

-------------------------------------------------------------------------

คราวนี้กลับกัน เครื่อง XP เข้าไปดูเครื่อง 7 ที่แชร์ไม่ได้ ฟ้องแบบเดียวกัน
ให้ไปแก้ที่ 7 ดังนี้

ไปที่ Start > Run พิมพ์ Regedit กด enter

HKEY_LOCAL_MACHINE\
System\
CurrentControlSet\
Control\
Lsa\

ทางขวามือ ให้เปลี่ยนค่าของ LimitBlankPasswordUse จาก 1 เป็น 0

ok
ปิดหน้าต่าง
restart
แล้วลองเข้าดูใหม่จ้า

เครดิต
http://www.notebook-lookup.com/blog/บันทึกช่าง-แก้ปัญหาเข้/

-------------------------------------------------------------

ดู แล้วทำตาม
https://youtu.be/kZmXil_ps2I
« แก้ไขครั้งสุดท้าย: ธันวาคม 08, 2016, 12:27:20 am โดย อ.สมฤกษ์ » บันทึกการเข้า
   
หน้า: [1]
  พิมพ์  
 
กระโดดไป:  

Powered by SMF 1.1.4 | SMF © 2006-2007, Simple Machines LLC | Thai language by ThaiSMF
Cennet By Burak
Valid XHTML 1.0! Valid CSS!